gfxgfx
 
Please login or register.

Login with username, password and session length
 
gfx gfx
gfx
75207 Posts in 13169 Topics by 2632 Members - Latest Member: kmcg3413 June 23, 2017, 10:35:17 pm
*
gfx*gfx
gfx
WinMX World :: Forum  |  Technical  |  Protocol Discussion  |  problem with key exchange
gfx
gfxgfx
 

Author Topic: problem with key exchange  (Read 1520 times)

0 Members and 1 Guest are viewing this topic.

newb

  • Guest
problem with key exchange
« on: November 30, 2006, 10:38:20 pm »
hi, i'm trying to make a server but the client disconnects as soon as it receives me keyblock.  i send the 1, verify the client's keyblock is type 0x57, and then make and send my own keyblock of type 0x58, and then the client disconnects.

i'm not using c so i had to rewrite the encryption functions.  but, i keep looking at it and i'm sure my functions are doing the same thing.  and i can double-check by calculating the key type for my own keyblock i made, and it comes out 0x58 like it's supposed to.

other than a problem with my keyblock functions, is there anything i could be missing?

thank you for your help.

KM

  • Guest
Re: problem with key exchange
« Reply #1 on: December 01, 2006, 09:40:47 am »
well, clearly you are doing something wrong in sending it out - as for what, only you'd be able to tell that...

of course the simplest things to check is that you're sending out the right amount of data, then check it's an actual valid key block

newb

  • Guest
Re: problem with key exchange
« Reply #2 on: December 01, 2006, 07:30:45 pm »
thanks for your time.  i figured out the problem, and am generating valid keyblocks now = )

WinMX World :: Forum  |  Technical  |  Protocol Discussion  |  problem with key exchange
 

gfxgfx
gfx
©2005-2017 WinMXWorld.com. All rights reserved.
SMF 2.0.14 | SMF © 2017, Simple Machines
Page created in 0.02 seconds with 14 queries.
Helios Multi © Bloc
gfx
Powered by MySQL Powered by PHP Valid XHTML 1.0! Valid CSS!