gfxgfx
 
Please login or register.

Login with username, password and session length
 
gfx gfx
gfx
75878 Posts in 13322 Topics by 2670 Members - Latest Member: pierced3x August 22, 2019, 09:06:29 pm
*
gfx*gfx
gfx
WinMX World :: Forum  |  WinMX Help  |  Upload/Download Issues  |  Vista + Router = Nightmare
gfx
gfxgfx
 

Author Topic: Vista + Router = Nightmare  (Read 963 times)

0 Members and 1 Guest are viewing this topic.

Offline alniter

  • Forum Member
Vista + Router = Nightmare
« on: May 13, 2008, 07:11:40 pm »
Hi all,

   I just added DSL to a Vista computer. I go through a Linksys WRT54GS router so my housemate can use his XP laptop on the network as well.

   I was having problems connecting so I looked up instructions on how to forward ports (and set a static IP address as well) for my brand of router in Vista. I followed it to the letter (checked it twice).

   If someone tries to get a file from me in WinMX now they get a "Waiting on incoming connection" message that eventually times out even tho I've got the file they want and no one ahead of them.

   If I try to download from others, success depends on initial contact. If the first message I get is "connecting to remote user" it connects, negotiates and commences just  fine. If my first message is "waiting on incoming connection" that's all I get until it times out. What am I missing? Any help is appreciated.

Offline Me Here

  • Ret. WinMX Special Forces
  • WMW Team
  • *****
  • We came, We Saw, We definatly Kicked Ass!
Re: Vista + Router = Nightmare
« Reply #1 on: May 13, 2008, 08:04:13 pm »
Hi Alniter,

Your not alone in your Vistaish nighmare lol but lets see if we cant get you working a bit better.

Downloads: 
These are generally not going to rely on ports at all, so if they are failing this makes me wonder what patch your using?  Make sure its the one from here:
http://patch.winmxconex.com/
This one filters fakes and often downloads not working is due to fake files.
If you are already using this patch i have one more suggestion.  Have a look at this page and pay special attention to the Auto Find Sources and Auto Enter Que settings.  Make sure and adjust those as recommended there and try downloads again.
http://www.winmxworld.com/help/winmx-settings-search.html

Uploads:
Linksys routers are pretty straight forward if your rules for it look similar to below

WinMXrule1    6699 to 6699  TCP  192.168.1.10x  Enabled
WinMXrule2    6257 to 6257  UDP  192.168.1.10x  Enabled

You're on the right track, only one thing I'll mention to check on this is make sure that your not using the Default Gateway (which for most Linksys routers is 192.168.1.1) in this IP Address field.  I've put 192.168.1.10x because most of the ones you need in this area will be 192.168.1.102 or 3
If you need to find the IP Address of your machine do this
Start > Run > type in        cmd
Then say OK
In the next black box type              ipconfig
Then hit enter.
     Your IP Address will be listed here.

Once you're sure thats not the problem next thing to look at is your firewall, Vista also has one built in and it will require you to set ports in it for both TCP and UDP as well if its enabled and on, here is a rough guide for you.
http://www.winmxworld.com/tutorials/vista_firewall.html

While your going thorugh this make sure the WinMX settings are as per those instuctions as well.

If your still having issues with uploads then I'd suggest checking your antivirus and see if it has a place to allow programs access to the internet etc.  And another thing built into Vista is Windows Defender, which luckily is usually just a matter of 'Allowing' WinMX full access.

If this still doesnt help then please post back and let us know.

Offline alniter

  • Forum Member
Re: Vista + Router = Nightmare
« Reply #2 on: May 14, 2008, 07:33:03 pm »
Everything you suggested was done already but double-checked it. I had used portforward.com's instructions both for my router and Vista. On paper (screen?) it looks like it should work. Before doing all this it wouldn't even connect so I know it's done something right, but not enough.

The only thing that has changed was going from dialup to DSL and using a router. Before that WinMX was a dream...a slow dream, but a dream. To now finally have speed and not be able to use it is frustrating to say the least. The most bizarre part is, like mentioned in my original post, it connects if I get "connecting to remote user" as the first message, but doesn't otherwise.

Suggestions appreciated but didn't work. Now what?  :shock:

Offline Me Here

  • Ret. WinMX Special Forces
  • WMW Team
  • *****
  • We came, We Saw, We definatly Kicked Ass!
Re: Vista + Router = Nightmare
« Reply #3 on: May 14, 2008, 09:55:00 pm »
The next thing i want you to try is this

Go to WinMX settings > Incoming TCP and set this to unable...

Then look at In/Out UDP and set this to unable.. .

Restart WinMX and report back to me if this works or not,  basically if this works the ports are still blocked in some place.


Offline Bearded Blunder

  • Forum Member
    • Taboo Community Website
Re: Vista + Router = Nightmare
« Reply #4 on: May 15, 2008, 02:13:44 am »
have you checked that your modem (if separate from your router) doesn't also function as a router (most dsl modems do), if it does i suggest the easiest solution is to use a network hub or switch instead of the separate router & forward in the modem instead .. (just a thought)
Blessed is he who expecteth nothing, for he shall not be disappointed.

Offline alniter

  • Forum Member
Re: Vista + Router = Nightmare
« Reply #5 on: May 20, 2008, 06:04:41 am »
With "Unable" chosen for both TCP and UDP, it works fine now! I take it not everyone needs the ports???? Happy, but confused now..LOL.

Offline SamSeeSam

  • Forum Member
  • The Sky will never Fall on our heads
Re: Vista + Router = Nightmare
« Reply #6 on: May 20, 2008, 07:13:16 am »
I guess it will work without any problems
only that you can't be connected as Primary
Other than that all other functions will work smoothly.

Cheers :P
Reconnect to winmx with the blocking patch :)
Patch link :
http://patch.winmxconex.com/

Spread the word now :)

Offline Me Here

  • Ret. WinMX Special Forces
  • WMW Team
  • *****
  • We came, We Saw, We definatly Kicked Ass!
Re: Vista + Router = Nightmare
« Reply #7 on: May 20, 2008, 09:24:56 am »
WinMX requires one of the two users transfering files to/from each other to have ports set up.  Setting you up this way was a test to see where the problem might lie.  I didnt see you answer Bearded's post and I'm inclined to think you may have a router and a dsl modem that both act as a Router (have NAT ability)  when this is the case there are more steps to go through in order for 'you' to set ports.

As you are now will indeed work fine for about 80% of tranfers, there will be some set as you are (we call it Passive Secondary Mode) and so for now sure, run it and enjoy but if you notice persistant problems with uploads/download from certain users and you want to change it we need to know more information about your set up.

WinMX World :: Forum  |  WinMX Help  |  Upload/Download Issues  |  Vista + Router = Nightmare
 

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Name: Email:
Verification:
Type the letters shown in the picture
Listen to the letters / Request another image
Type the letters shown in the picture:
What year is it next year?:
What's the name of the site this forum belongs to?:
What program is this site about?:

gfxgfx
gfx
©2005-2019 WinMXWorld.com. All rights reserved.
SMF 2.0.15 | SMF © 2017, Simple Machines
Page created in 0.04 seconds with 22 queries.
Helios Multi © Bloc
gfx
Powered by MySQL Powered by PHP Valid XHTML 1.0! Valid CSS!