WinMX World :: Forum

WinMX Help => Upload/Download Issues => Topic started by: bazmich on July 02, 2009, 09:07:29 pm

Title: All uploads timeout waiting for incoming connection.
Post by: bazmich on July 02, 2009, 09:07:29 pm
Recently changed ISP from Tiscali to Plusnet. Since, I have not had a single successful upload as they all timeout waiting for incoming connection. I have forwarded my ports with simple port forwarding 6699 - 6257. I download with no problems.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: ñòóKýçrÕôK on July 03, 2009, 07:50:28 am
A few things we need to know here please. What OS are you on, XP, Vista? What antivirus and/or firewall? Are you using windows firewall? Have you tried reallowing WinMX through windows firewall? Sometimes even not running it will block already allowed programs for some reason. To reallow, if windows firewall is disabled then reenable it. Remove WinMX.exe from the firewall with WINMX closed, then restart WinMX with the firewall running and reallow it. Then you can disable it again if you want. Please also list anything else you've tried to make it work no matter how small it seems. Could make a difference. Good luck :)
Title: Re: All uploads timeout waiting for incoming connection.
Post by: bazmich on July 03, 2009, 09:25:24 pm
Hi, I'm using Vista, AVG 8.5 antivirus with firewall. This automatically turns off Windows firewall. Have not tried anything else as I'm stumped as to why it doesn't work when I can download with no problems. Seems the firewall settings are allowing Winmx to download. Sorry for this but I'm not expert on the subject. I have been running Winmx many years but never had this problem before.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: Forested665 on July 03, 2009, 11:42:40 pm
Make sure the AVG firewall is set to allow both incoming and outgoing connections for winmx.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: ñòóKýçrÕôK on July 04, 2009, 01:12:50 am
If you will go ahead and do what I said also in my first post to reallow winmx in windows firewall just to be safe. You can find winmx.exe in control panal/windows firewall, then exceptions tab in windows firewall. Just remove it from there with winmx closed and then restart winmx and reallow it. Let me know how that goes please.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: bazmich on July 04, 2009, 07:48:26 pm
Hi nookycrOok, done as you suggested. Re-enabled Windows firewall and allowed Winmx application thru. Also checked that Winmx application was allowed in AVG firewall, it was. Although I turned Windows firewall on I think AVG firewall overrode it. Nobody can still upload from me. Does this help?
Title: Re: All uploads timeout waiting for incoming connection.
Post by: Savage Blades on July 04, 2009, 08:47:07 pm
when you changed companies did they supply new hardware IE modem/router ?
if so make & model please ?
Also go to http://canyouseeme.org
test TCP port (6699 is default) that winmx is set to and see if it is open.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: bazmich on July 05, 2009, 04:28:42 pm
Hi Savage Blades, yes Plusnet gave me a new router a Thomson TG585 v7, which I could not get connected with so I went back to my old Tiscali router a Thomson Speedtouch 510 v6. Which is where I am now. I entered 6699 in canyouseeme check port and got message 'I could not see your service on port 6699, reason connection timed out'. I also entered port 6257 with the same result. Many Thanks.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: Forested665 on July 05, 2009, 07:08:30 pm
That means the port is still closed.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: ñòóKýçrÕôK on July 05, 2009, 09:44:49 pm
According to what I found on portforward's site forum you would foward that Thomson TG585 v7 by the model found at this address  ---> http://www.portforward.com/fpa.cgi?data=Thomson-Alcatel---SpeedTouch585---WinMX  . And it's probably the only router your isp is allowing access. Seems to me someone else who had switched routers without the isp's knowing ended having to call their isp to get it allowed. The address where I found which router to go with is ----->  http://forum.portforward.com/YaBB.cgi?num=1224326446/2  if you wish to check it out yourself. One tip though. When you go to the address up there to foward it look up to the top right and click skip this add, then proceed. Hope it helps, let us know.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: bazmich on July 07, 2009, 03:19:34 pm
Hi nooKycrOoK, followed all portforward instructions on reinstalling Thomson 585 v7 router and making sure that ip static address, subnet mask, default gateway and name servers were correctly listed in Network and sharing settings. Then followed and inserted new ports (17618 TCP and 18547 UDP) in their port forwarding for Winmx. After which I used their checking tool to see if ports were open for both TCP and UDP and got reply, 'your port is not open or not reachable'. Still having same problem. Many Thanks for your advice, is there anything else I can try.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: Forested665 on July 07, 2009, 04:53:24 pm
Are you using any firewalls and is there another box in your lineup say Modem-> router-> pc
If so your modem might also have a NAT which makes it a router too.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: bazmich on July 07, 2009, 06:28:12 pm
I am using AVG firewall as mentioned above, but Winmx is allowed thru. Windows firewall is disabled although Winmx is also allowed thru. I cant see any other modem in Device manager.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: Forested665 on July 07, 2009, 09:55:02 pm
Dont look in device manager.
Look around your desk the modem and router are physical items that your pc is plugged into.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: ñòóKýçrÕôK on July 08, 2009, 01:42:36 am
Then followed and inserted new ports (17618 TCP and 18547 UDP) in their port forwarding for Winmx.

Now are these the same ports, 17618 for tcp and 18547 for udp which are in your winmx the program? And try going to the port checker site with avg turned off completely, see how that goes. Let us know.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: bazmich on July 08, 2009, 07:11:39 pm
Hi nooKycrOok, yes, the ports I listed in router I had already put in Winmx program. Turned AVG firewall off and got same message when I used Port Checker.'Your port is not open or not reachable'. Many Thanks for your continued interest.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: Forested665 on July 08, 2009, 07:35:55 pm
Have you checked your net set up like i asked? You could be behind two routers.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: bazmich on July 08, 2009, 08:09:22 pm
The only things plugged into my PC are, Thomson router TG585 v7, speakers (2), all in one printer, keyboard and mouse. Many thanks.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: Forested665 on July 08, 2009, 09:51:25 pm
The router isnt plugged into anything?
Title: Re: All uploads timeout waiting for incoming connection.
Post by: ñòóKýçrÕôK on July 09, 2009, 05:38:24 am
Something you may wish to try being on vista is go into your winmx folder and right click on winmx.exe and click properties. Once that comes up if it isn't checked put a check in the box beside "Run as Administrator" then click apply and ok and then start winmx. Might even benefit to click on the Compatibility tab under winmx.exe properties and set it to run as XP SP2 compatibility. Could be that it needs the admin privelidges to get through windows. I never had the issue on Vista but I know others have. Let us know how it goes. *edit* Also while in the winmx folder open oledlg.ini and change the 1 beside the enable upnp to a 0 to be sure it's not hampering your router settings you're making in fowarding your ports then go back to portfoward and doublecheck that they're still the same please.   :D
Title: Re: All uploads timeout waiting for incoming connection.
Post by: bazmich on July 09, 2009, 06:15:44 pm
Checked box 'Run as Administrator', applied and OK'd. Clicked on compatibility tab and changed to XP SP2. Opened file oledlg.ini and it opened up as oledlg notepad. Changed the 1 to 0 beside the enable upnp. Clicked on save and was told the file exists and did I want to replace it, (yes or cancel) I clicked yes but then received message 'Please make sure the correct path and filename are correct. This appeared in front of a screen entitled C:\Program Files\Winmx which was empty. I tried a further 10 times to change the 1 to 0 but every time same result. The only way I could exit the screen was to cancel it which reverted the 0 back to 1. Checked both ports with Portforward Port Checker, and received same message for TCP and UDP, 'Your port is not open or unreachable'. Sorry I could not report a happier outcome.
Regarding Forested665 point. The router is plugged into the back of my PC with a yellow cable, and a black cable plugs into a microfilter which plugs into the BT incoming wall socket.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: Forested665 on July 09, 2009, 08:03:38 pm
heres what you can do.
Open notepad.
Paste this into it
Code: [Select]
/enablefilter 1
/enableupnp 0
/showblocks 1
/upnpreopen 14400
/webaddr mainbar.winmxworld.com
/cache cache0.winmxworld.net
/cache cache1.winmxworld.net
/cache cache2.winmxworld.net
/cache cache3.winmxworld.net
/cache cache4.winmxworld.net
/cache cache5.winmxworld.net
/cache cache6.winmxworld.net
/cache cache7.winmxworld.net
/cache cache8.winmxworld.net
/cache cache9.winmxworld.net
/cache cache0.winmxcache.com
/cache cache1.winmxcache.com
/cache cache2.winmxcache.com
/cache cache3.winmxcache.com
/cache cache4.winmxcache.com
/cache cache5.winmxcache.com
/cache cache6.winmxcache.com
/cache cache7.winmxcache.com
/cache cache8.winmxcache.com
/cache cache9.winmxcache.com
/cache cache0.winmxconex.net
/cache cache1.winmxconex.net
/cache cache2.winmxconex.net
/cache cache3.winmxconex.net
/cache cache4.winmxconex.net
/cache cache5.winmxconex.net
/cache cache6.winmxconex.net
/cache cache7.winmxconex.net
/cache cache8.winmxconex.net
/cache cache9.winmxconex.net
/cache cache0.winmxcache.net
/cache cache1.winmxcache.net
/cache cache2.winmxcache.net
/cache cache3.winmxcache.net
/cache cache4.winmxcache.net
/cache cache5.winmxcache.net
/cache cache6.winmxcache.net
/cache cache7.winmxcache.net
/cache cache8.winmxcache.net
/cache cache9.winmxcache.net
/cache cache0.winmxconex.com
/cache cache1.winmxconex.com
/cache cache2.winmxconex.com
/cache cache3.winmxconex.com
/cache cache4.winmxconex.com
/cache cache5.winmxconex.com
/cache cache6.winmxconex.com
/cache cache7.winmxconex.com
/cache cache8.winmxconex.com
/cache cache9.winmxconex.com
/cache cache0.mxpie.co.uk
/cache cache1.mxpie.co.uk
/cache cache2.mxpie.co.uk
/cache cache3.mxpie.co.uk
/cache cache4.mxpie.co.uk
/cache cache5.mxpie.co.uk
/cache cache6.mxpie.co.uk
/cache cache7.mxpie.co.uk
/cache cache8.mxpie.co.uk
/cache cache9.mxpie.co.uk

Click save as, select a folder someplace temporary like your desktop.
select the drop down menu for save as type and select all files instead of txt
type oledlg.ini as the filename.

Open your winmx folder delete the old oledlg.ini and replace it with the new one.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: Joshua203 on July 09, 2009, 08:57:58 pm
i think it might be read only for some silly reason?
Title: Re: All uploads timeout waiting for incoming connection.
Post by: ñòóKýçrÕôK on July 09, 2009, 09:29:06 pm
Changed the 1 to 0 beside the enable upnp. Clicked on save and was told the file exists and did I want to replace it, (yes or cancel) I clicked yes but then received message 'Please make sure the correct path and filename are correct. This appeared in front of a screen entitled C:\Program Files\Winmx which was empty. I tried a further 10 times to change the 1 to 0 but every time same result.

The reason it did that is because you were using WinMX at the time. It's an ini file and as long as MX is in use it is in use. Try editing and saving it while WinMX is not running. Would have to restart MX afterwards anyway so you may as well shut it down while changing it.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: bazmich on July 10, 2009, 06:30:17 pm
It worked, thanks to you. Portforward reports both ports open and I'm getting uploads as well as downloads. Once again MANY THANKS.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: Forested665 on July 10, 2009, 10:23:20 pm
wow... upnp reeks havoc once again...
Title: Re: All uploads timeout waiting for incoming connection.
Post by: ñòóKýçrÕôK on July 11, 2009, 04:14:27 pm
Just glad we could help. :D and you're very welcome.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: Juno on July 29, 2009, 04:32:36 pm
Hello. I've been using winmx for years now. I also use Mirc. In the last few months I started having problems with up-loads on both programs. After 2 months of aggrivation, we finally figured out that my ISP was blocking uploads or ports. Installed OpenSSL and now my Mirc uploads are working fine. Winmx is still not uploading. Is there a simular fix for Winmx?
Title: Re: All uploads timeout waiting for incoming connection.
Post by: Stevi on July 29, 2009, 07:03:56 pm
Have you tried changing your ports for WinMX?
Title: Re: All uploads timeout waiting for incoming connection.
Post by: Forested665 on July 30, 2009, 03:16:43 am
I'm sorry but winmx does not support SSL tunneling.
SSl had a bad reputation when it first came out and the first stable version was released in 96 and most modern applications were not implemented until 99 so the technology was still new for all practical purposes bleeding edge when development on winmx stopped.

I would suggest doing as xapien has suggested.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: Juno on July 31, 2009, 04:43:33 pm
Ok, will try changing ports! I'll let you know how it goes. Thanks a bunch.
Title: Re: All uploads timeout waiting for incoming connection.
Post by: vsovereign on September 05, 2009, 05:07:24 pm
Hi there!
I have the same problem. I'm behind LAN & tried to change my connection from Microsoft VPN to CISCO.
I can donwload it seems, but uploads all timed out.

If anyone can help, thanks!