gfxgfx
 
Please login or register.

Login with username, password and session length
 
gfx gfx
gfx
76197 Posts in 13396 Topics by 2074 Members - Latest Member: Herbert1025 February 24, 2020, 11:07:51 am
*
gfx*gfx
gfx
WinMX World :: Forum  |  WinMX World  |  Site Feedback  |  forum css bugs...
gfx
gfxgfx
 

Author Topic: forum css bugs...  (Read 5699 times)

0 Members and 1 Guest are viewing this topic.

Offline White Stripes

  • Core
  • *****
  • ***
  • Je suis aimé
forum css bugs...
« on: January 21, 2010, 04:02:35 am »
Code
input.check { 
border : 0 solid #909090;
background-color : #000;
color : black;
}

invisible checkbox bug... been with the site since day 1.... the sites always had a stylesheet... dunno what you 'converted' ..... (the bug? the background of the checkbox itself is set to '#000'... black... while also having the checkmark itself specified in plain english as 'black')

Code
.normaltext { 
font-size : 1em;
font-family : tahoma, helvetica, serif;
}

font bug... makes the regular text much bigger than the rest.... should be .95 like the rest of the site... with no font face specified .... not everyone has the same set of fonts as everyone else...  

...the radio buttons used in polls are invisible too... (i click then click 'vote' and hope what i selected works) but ive yet to narrow that one down....

www.opera.com (does what its told... heres a tip; -never- rely on quirks mode... always double check your css so that you dont end up with... say.. a blank checkbox bug that is technically valid css.... ...blank checkbox isnt your fault tho... was inherited from the original design by bloc...)

Offline nylly444

  • The /root of all evil ;-)
  • WMW Team
  • *****
Re: forum css bugs...
« Reply #1 on: January 21, 2010, 02:29:07 pm »
ok, let's clear up the terminology:  The SITE ist www.winmxworld.com, this however, is the FORUM.

The Site has a stylesheet too as does the archive, but you're obviously referring to the forum styles here.  

I changed the checkbox font color (most browsers use the OS settings here it seems), let me know if it works for you now, should have the same color as the "Post" button below.

The text property as defined in  .normaltext is only used in the admin template afaik, not at all in the board or message index.
I changed it to 0.95 but that *shouldn't* do anything anyway, we could just as well delete that from the style sheet completely.

Generally the forum's default style sheet uses a font size of 0.95em for the body element, which means it's 0.95% of the font size your browser is set to use , default for most browsers is 16pt here.
The whole forum again is a table which uses 0.975 of that 0.95% for the default cells, and the smaller text is as defined in  .smalltext in the style sheet, which is .875em of that .095 again.

Please let me know exactly what elements are displayed too big in your opinion so that I can look in detail at what properties apply to it.
The whole style sheet is quite complicated insofar as it is truly a "cascaded" style sheet which means there's a lot of "nested" stuff, i.e. some properties get inherited from multiple parent elements.
I need some details here please to figure it out :)
LINUX - Legendary Intelligent Needful Universal Xperienced

Offline White Stripes

  • Core
  • *****
  • ***
  • Je suis aimé
Re: forum css bugs...
« Reply #2 on: January 21, 2010, 07:28:03 pm »
continuing here to keep off topic clutter out of non forum css bug topic...

posting screenshots... and yay! i can finally see the checkboxes without turning css off! many thankees!

ok... the mozilla/seamonkey screenshot is 'right' on sizes... dont mind the font faces.... im .. well.. rather limited in my choices... and ive gotten used to it... so no biggie... (yes this is a linux box)

but the opera screenshot has 'balloon' sized fonts, in that screenshot, everywhere but the 'quote' box...

in opera font sizes for the header (around the avatar pic) and the navigation header (just above forum and just below the 'home' 'search' 'help' etc... buttons) and the 'last post by' in the forum table are correct size... ...everywhere else its the 'balloon' font... its been like this since the mxmas decorations were taken down.... so... a typo or bug happened somewhere in 'undecorating' the forum....

Offline nylly444

  • The /root of all evil ;-)
  • WMW Team
  • *****
Re: forum css bugs...
« Reply #3 on: January 21, 2010, 08:10:26 pm »
ok, let's try to sort this out:

First of all when on Linux the only thing microsoft you really need is this: http://corefonts.sourceforge.net/  
These are the MS corefonts (Arial, times new roman, verdana, andala mono), relased as open source afaik
They might be available in your package system as well, look for "msttcorefonts".

The difference you're seeing is not so much in sizes as in font faces I believe.
The smaller font is set to verdana/helvetica/serif, the bigger one is tahoma/helvetica/serif.
The font size is dependent on your browser set size but I'm not sure about font replacements in opera.
(I've always hated that one with a passion for some reason, lol)
That's something you might want to look into - or simply put tahoma into your fonts as well (not provided with msttcorefonts but available with wine).

Tell you what - I'll attach it ;)

...and also attached a screenshot how it's supposed to look :)

*edit: split away the other posts and merged with this one
LINUX - Legendary Intelligent Needful Universal Xperienced

Offline White Stripes

  • Core
  • *****
  • ***
  • Je suis aimé
Re: forum css bugs...
« Reply #4 on: January 21, 2010, 10:17:14 pm »
test... (humor me ;) )

normal text....

normal text with smiles :) :( :P :wink: :3

Quote
quoted text .... yadadada foooobar...
* Silver Stripes tests 'me' emote/pose thing....

Code
'code' text test .....
next line
next line again...



-edit-

using adobe utopia instead of adobe times (fall back font if no other specified typeface is available) makes things better :3

trying to get away from putting micro$oft fonts on a linux box >.>  .... which .... ill probably end up doing anyway.....


-edit 2-

still funky that this didnt show till after the mxmas change....

Offline nylly444

  • The /root of all evil ;-)
  • WMW Team
  • *****
Re: forum css bugs...
« Reply #5 on: January 21, 2010, 11:01:18 pm »
Try the bitstream vera fonts if you want to avoid MS fonts. http://www.gnome.org/fonts/

OH, and I didn't quite make it clear that that tahoma font I attached isn't the original MS font but a replacement by the wine team as many windows apps use that font and need it with exactly that name to work under wine.

Give it a try, hehe.

Oh, and I just checked with the x-mas stylesheet and it seems there was no font set for the message index so I removed it from the current style sheet as well...
LINUX - Legendary Intelligent Needful Universal Xperienced

Offline White Stripes

  • Core
  • *****
  • ***
  • Je suis aimé
Re: forum css bugs...
« Reply #6 on: January 22, 2010, 01:31:59 am »
im grabbing the ms core (a bit of a pain... even when using the wintendo with winrar installed) and the tahoma you posted.... ...rather use fonts i know will work than chance it with the bitstream vera fonts.... tho i used to have a -huge- collection of bitstream fonts that came on floppy disk a long time ago... used them along with the fonts in the 'fonts' directory of windows 98 on a previous linux install :P

btw, the tahoma font you posted says copyright 2004 microsoft... you sure it was made by the wine team? :wink:

oh... and taking the font faces out of message index part of the sheet caused things to go in reverse.... now the 'bubble font' is in the reply box and quoted text...... lmao.... will be setting the different fonts tho so we'll how that goes in a bit... :P

Offline White Stripes

  • Core
  • *****
  • ***
  • Je suis aimé
Re: forum css bugs...
« Reply #7 on: January 22, 2010, 02:56:45 am »
well... now i have a whole new look... but still not right... its readable... ill tweak it later...

Offline nylly444

  • The /root of all evil ;-)
  • WMW Team
  • *****
Re: forum css bugs...
« Reply #8 on: January 23, 2010, 12:52:04 pm »
btw, the tahoma font you posted says copyright 2004 microsoft... you sure it was made by the wine team? :wink:

Well, I did copy them directly from the wine folder, but I've downloaded them separately before so they might be relased under some form of public license as well.
I don't think they'd be included with the wine source code otherwise...

That font can be downloaded from microsoft directly here btw, but comes in form of an executable (.exe), so the fonts need to be extracted first to be usable.

And installing the MS corefonts depends on your linux distro, many already include them as a package.
LINUX - Legendary Intelligent Needful Universal Xperienced

WinMX World :: Forum  |  WinMX World  |  Site Feedback  |  forum css bugs...
 

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Name: Email:
Verification:
Type the letters shown in the picture
Listen to the letters / Request another image
Type the letters shown in the picture:
What program is this site about?:
What year is it next year?:
What's the name of the site this forum belongs to?:

gfxgfx
gfx
©2005-2020 WinMXWorld.com. All Rights Reserved.
SMF 2.0.17 | SMF © 2019, Simple Machines
Page created in 0.023 seconds with 25 queries.
Helios Multi © Bloc
gfx
Powered by MySQL Powered by PHP Valid XHTML 1.0! Valid CSS!