gfxgfx
 
Please login or register.

Login with username, password and session length
 
gfx gfx
gfx
76732 Posts in 13481 Topics by 1646 Members - Latest Member: Ftool May 28, 2023, 12:23:02 am
*
gfx*gfx
gfx
WinMX World :: Forum  |  Third Party Stuff  |  Chat Servers  |  WCS Glitch
gfx
gfxgfx
 

Author Topic: WCS Glitch  (Read 11191 times)

0 Members and 1 Guest are viewing this topic.

Offline Snick512

  • Forum Member
WCS Glitch
« on: May 18, 2007, 01:33:26 am »
Hmmm, the WCS Rooms i go into do this when i'm admin





;/

Offline Josh

  • Forum Member
  • Thinking about tomorrow...
    • http://www.winmxunlimited.net
Re: WCS Glitch
« Reply #1 on: May 18, 2007, 02:13:05 am »
That is the new bot mode for the new betas. WCS now sends the real color codes when you're in bot mode. So no need to worry. It isn't a glitch. :-)
- Josh

Offline Snick512

  • Forum Member
Re: WCS Glitch
« Reply #2 on: May 18, 2007, 02:25:22 am »
What? I'm not talking about the colour codes.. i'm talkin about the fucked format ...

KM

  • Guest
Re: WCS Glitch
« Reply #3 on: May 18, 2007, 02:27:11 am »
erm...

which WCS version? what's the text format set to? what is your exact username? and i'm assuming that's robomx - does it look normal in winmx?

although it's probably best if i can see this one for myself... lol

Offline Snick512

  • Forum Member
Re: WCS Glitch
« Reply #4 on: May 18, 2007, 02:41:55 am »
I'm using newest robomx, and yea it looks the same on winmx as it does on robo.

and i think its the newest version of wcs...

[18:37:48] Info: Room is powered by WCS 1.8b12-Win32

n um it doesnt say which format i'm on in 1 room, in the other its format 6

if u want the roomname i'll pm it to you

Offline Snick512

  • Forum Member
Re: WCS Glitch
« Reply #5 on: May 18, 2007, 02:43:16 am »
#c22#°°#c9#¨ #c10#Snick #c9#¨#c22#°°512

my exact username, forgot that part

KM

  • Guest
Re: WCS Glitch
« Reply #6 on: May 18, 2007, 02:46:48 am »
i meant the actual format, not which setting it is... lol  (and it's displayed in /stats <username> now)

btw i'm in the winmxworld room atm and will be for a short while...

KM

  • Guest
Re: WCS Glitch
« Reply #7 on: May 18, 2007, 03:19:56 am »
just for anyone wondering, he came in and I found the problem quite quickly, it's down to #c10# and the way WCS handles the newline in b12/13, it will be fixed in the next version but it's only a minor bug as there are plenty more grey colours to chose from so no reason someone has to use #c10# ;-)

Offline Bearded Blunder

  • Forum Member
    • Taboo Community Website
Re: WCS Glitch
« Reply #8 on: May 18, 2007, 10:27:25 am »
#c10# is quite pretty on other servers.. lots of ppl use it it comes out the same as #c51#
Blessed is he who expecteth nothing, for he shall not be disappointed.

KM

  • Guest
Re: WCS Glitch
« Reply #9 on: May 18, 2007, 11:28:09 am »
it's grey on WCS, the same as #c9# ;-)

but of course if you do want #c10# for that purpose..

Replace=#c10#=#c9#

although if you do have users doing that with their names i'd suggest Replace=#c10#=#c51# and while you're at it might as well do the others as well ;-)

Offline Lagerlout666

  • Forum Member
Re: WCS Glitch
« Reply #10 on: May 18, 2007, 11:37:04 am »
lol nice nobody blamed my room, it was my room after all lol
 I tought it was something id done and tried to fix. but got too tired and went to bed,never thought for a sec it was a bug. Ill have to blame KM more often instead of trusting your usuall good work lol ;-)
The Solution to 99% of winmx problems

nap.winmxgroup.net        -ONLINE again YAY!!!!!! :D

Praise's daily at the church of "Kopimi"

KM

  • Guest
Re: WCS Glitch
« Reply #11 on: May 18, 2007, 11:54:10 am »
blame ouka for users using that code :-P

it's just due to a few changes with how it handles multiple lines now (done at the same time i added #\n#), #c10 comes out as colour code followed by byte 10, byte 10 would be a line break - which just happens to be what I picked to use for splitting up lines in multi-line text, heh

Offline Bearded Blunder

  • Forum Member
    • Taboo Community Website
Re: WCS Glitch
« Reply #12 on: May 18, 2007, 02:48:55 pm »
lol, i hadn't seen the issue , but already had all the ouka codes in replace to wcs ones (as indeed my ouka room has all the wcs ones set to return the expected colour for wcs users)  in a perfect world wcs would support both sets of numbers (ok it supports them... just all as grey).. but it would be nice if both sets functioned, it's no problem using replace in room for text.. but it does rather spoil the effect for names when an ouka user wanders in a wcs room or vice-versa
Blessed is he who expecteth nothing, for he shall not be disappointed.

KM

  • Guest
Re: WCS Glitch
« Reply #13 on: May 18, 2007, 07:06:53 pm »
actually I knew fxserver support both types of color code, and had assumed ouka did as well... so didn't see any point, heh

Offline Bearded Blunder

  • Forum Member
    • Taboo Community Website
Re: WCS Glitch
« Reply #14 on: May 18, 2007, 09:06:34 pm »
well Ouka Chat Server, Ver.5.40a certainly doesn't & I havn't seen an anouncement of support for wcs codes being added, or i would have upgraded..... i know he added #c?# in addition to #cx# but that is the extent of compatibility i know of for certain......

since WCS's "bot friendly" output seems to only be readable by *some* bots *sometimes* it looks like i may be sticking with ouka & find out if the current one suports WCS codes in use.. at least Ouka's server messages CAN be read by metis..

a shame, because at least on paper WCS *looks* the way better option
Blessed is he who expecteth nothing, for he shall not be disappointed.

Micromecca

  • Guest
Re: WCS Glitch
« Reply #15 on: May 18, 2007, 10:07:37 pm »
I's love to see all colours added to WCS especilly c37  :lol:

KM

  • Guest
Re: WCS Glitch
« Reply #16 on: May 19, 2007, 03:17:49 am »
all outputs are basically sent as normal messages from the server, it should be extremely easy for bots to pick up every single output from it (obviously /notice it won't matter, due to the nature of the command)... which outputs are you having a problem with? there are a few people who do quite a bit of stuff with their bots who have been playing about with b12/b13 and none of them have mentioned any outputs not being easy to read so far... in fact the exact opposite response from them :-S

Offline Stevi

  • #1 DJ
  • MX Hosts
  • *****
  • Ooops! I blew up the commercials!
    • WinMX Radio
Re: WCS Glitch
« Reply #17 on: May 19, 2007, 06:09:06 am »
Well I have another one for you KM.

Every time i reload the room without rebooting it the MOTD shows up 2 times when using MOTDLine=. This happened to me 2 times. Every time I hit the reload button it puts a new MOTD up. I dont know what is going on here. I hope it is a glitch in wcs and not me. lol


[Edit by Omega] It seems as though if you dont have MOTD= aswell this problem occurs. If that is the way it is supposed to be I am sorry for wasting your time[/Edit]

Offline Bearded Blunder

  • Forum Member
    • Taboo Community Website
Re: WCS Glitch
« Reply #18 on: May 19, 2007, 08:23:58 am »
since WCS's "bot friendly" output seems to only be readable by *some* bots *sometimes* it looks like i may be sticking with ouka & find out if the current one suports WCS codes in use.. at least Ouka's server messages CAN be read by metis..
* Bearded Blunder has the bug it turns out

don't waste a lot of time trying to reproduce this.. however if you do want to, the methd is.. stay awake a long time, so you don't realise you're editing the xml files in the backup copy of metis you made to recover in case of total screwups.. while running the main copy.. it also helps to have many instances of notepad open..
:oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops:  :oops: 

but i do second the idea it would be nice to see the ouka codes actually added.. although i see no particular reason to add them to the /colour command (being duplicates) merely to have them work
Blessed is he who expecteth nothing, for he shall not be disappointed.

Offline nylly444

  • The /root of all evil ;-)
  • WMW Team
  • *****
    • WinMX World
Re: WCS Glitch
« Reply #19 on: May 19, 2007, 09:05:29 am »
@ Omega:

I had the same happen and after asking KM he said the MOTDLine is supposed to be added to the MOTD.
It works fine if you do that, it just needs to be documented properly :P
* nylly444 blames KM
LINUX - Legendary Intelligent Needful Universal Xperienced


WinMX World :: Forum  |  Third Party Stuff  |  Chat Servers  |  WCS Glitch
 

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Name: Email:
Verification:
Type the letters shown in the picture
Listen to the letters / Request another image
Type the letters shown in the picture:
What program is this site about?:
What year is it next year?:
What's the name of the site this forum belongs to?:

gfxgfx
gfx
©2005-2023 WinMXWorld.com. All Rights Reserved.
SMF 2.0.19 | SMF © 2021, Simple Machines | Terms and Policies
Page created in 0.024 seconds with 24 queries.
Helios Multi © Bloc
gfx
Powered by MySQL Powered by PHP Valid XHTML 1.0! Valid CSS!