gfxgfx
 
Please login or register.

Login with username, password and session length
 
gfx gfx
gfx
76648 Posts in 13454 Topics by 2082 Members - Latest Member: nike66 September 19, 2021, 11:46:20 am
*
gfx*gfx
gfx
WinMX World :: Forum  |  Discussion  |  WinMx World News  |  New in-the-wild attack targets fully-patched Adobe Reader
gfx
gfxgfx
 

Author Topic: New in-the-wild attack targets fully-patched Adobe Reader  (Read 685 times)

0 Members and 1 Guest are viewing this topic.

Offline DaBees-Knees

  • WMW Team
  • *****
New in-the-wild attack targets fully-patched Adobe Reader
« on: February 20, 2009, 12:19:05 pm »
http://www.theregister.co.uk/2009/02/20/adobe_reader_exploit/

Quote
Security watchers are warning of a serious unpatched vulnerability in Adobe's Reader program that's actively being exploited to install malware on the PCs of unsuspecting users. The vulnerability has been confirmed in versions 8.1.3 and 9.0.0 of Adobe Reader running on Windows XP Service Pack 3 and is presumed to work on other versions of Windows as well, according to this advisory from Shadowserver. Adobe for machines running Linux and Apple's OS X were not tested, but may also be vulnerable, Shadowserver's Steven Adair said. There are multiple variants of the exploit that are actively circulating, one of which installs a remote access trojan known as Gh0st RAT. "Right now we believe these files are only being used in a smaller set of targeted attacks," Shadowserver's advisory read. "However, these types of attacks are frequently the most damaging and it is only a matter of time before this exploit ends up in every exploit pack on the internet." Several anti-virus programs are already detecting the booby-trapped PDFs. Trend Micro and Symantec flag the attack as TROJ_PIDIEF.IN and Trojan.Pidief.E respectively. Both companies rate the threat as low, but those analyses appeared to be a week old, so it's likely attackers have stepped up the exploit since then. Adobe has issued this advisory aknowledging a "critical vulnerability" in Reader. Updates won't be available until March 11 for version 9 and a later date for earlier versions. InsecureWeb has also issued details. The toxic PDFs attack a vulnerability that resides in a non-javascript call and "use some javascript to implement a heap spray for successful code execution," according to an analysis security researcher Matthew Richard provided for Shadowserver. "The malicious PDFs in the wild contain javascript that is used to fill the heap with shellcode." Shadowserver is recommending people disable javascript in Reader, a measure that's probably not a bad idea even in the best of times. To do so, open Reader and then click Edit > Preferences > JavaScript and then uncheck the box that says Enable Acrobat JavaScript.

You have been warned  :pray:

Offline White Stripes

  • Core
  • *****
  • ***
  • Je suis aimé
Re: New in-the-wild attack targets fully-patched Adobe Reader
« Reply #1 on: February 20, 2009, 12:56:16 pm »
...when the hell did they include javascript in pdf? ... and whose brilliant idea was this?


[EDIT] addendum;

simple fix.... use; http://www.foolabs.com/xpdf/

theres a DOS version available... i dunno if it'll work in winnt/2k/xp/gwiz but it doesnt do javascript....

unfortunatly no windows verison...

Offline p2p rules

  • Forum Member
Re: New in-the-wild attack targets fully-patched Adobe Reader
« Reply #2 on: February 20, 2009, 08:11:37 pm »
I use SumatraPDF open-source PDF viewer for Windows.

Offline Daniel

  • Forum Member
  • chiot mignon
Re: New in-the-wild attack targets fully-patched Adobe Reader
« Reply #3 on: February 21, 2009, 07:53:25 pm »
I don't think anyone here uses adobe pdf reader. :no:

I use Foxit reader.
- Have a nice explosive day.

WinMX World :: Forum  |  Discussion  |  WinMx World News  |  New in-the-wild attack targets fully-patched Adobe Reader
 

gfxgfx
gfx
©2005-2021 WinMXWorld.com. All Rights Reserved.
SMF 2.0.18 | SMF © 2021, Simple Machines | Terms and Policies
Page created in 0.046 seconds with 25 queries.
Helios Multi © Bloc
gfx
Powered by MySQL Powered by PHP Valid XHTML 1.0! Valid CSS!